Tuesday, August 15, 2017

How To Blok Torrent Via Mikrotik Router


Asume you want to block torrent & p2p traffic on 192.168.1.0/24
replace ip according to your need


/ip firewall layer7-protocol>
use winbox to copy paste name=torrentsites
regexp:
^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|torrentz|vertor|h33t|btscene|bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|bitsoup|meganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*$


/ip firewall filter>
add chain=forward src-address=192.168.1.0/24 layer7-protocol=torrentsites action=drop comment=torrentsites
add chain=forward src-address=192.168.1.0/24 protocol=17 dst-port=53 layer7-protocol=torrentsites action=drop comment=dropDNS
add chain=forward src-address=192.168.1.0/24 content=torrent action=drop comment=keyword_drop
add chain=forward src-address=192.168.1.0/24 content=tracker action=drop comment=trackers_drop
add chain=forward src-address=192.168.1.0/24 content=getpeers action=drop comment=get_peers_drop
add chain=forward src-address=192.168.1.0/24 content=info_hash action=drop comment=info_hash_drop
add chain=forward src-address=192.168.1.0/24 content=announce_peers action=drop comment=announce_peers_drop

& also use default rule to drop p2p traffic which alone is not working for me

add chain=forward src-address=192.168.1.0/24 p2p=all-p2p action=drop comment=p2p_drop


Enjoy

Tags : Blok Torrent mikrotik, blok torrent, mikrotik

Wednesday, August 9, 2017

MEmu How to Enable Hardware Virtualization


#How to enable hardware virtualization in Android Emulator?#

MEmu App Player will have better performance if hardware virtualization (aka Intel-VT or AMD-V) is enabled on your computer. Most of mainstream Intel and AMD CPUs support this feature.

If it’s not enabled properly, we recommend you to enable it by following steps:

1. Download a 3rd-party tool: LeoMoon CPU-V to detect your CPU’s capability.

2. If get the result as below, that means your CPU is too old… bad news

3. If get the result as below, you need enable this feature in BIOS by yourself.

Step 1. Press a designated key repeatedly (depends on your machine vendor, e.g. F2 or Del works for most Dell) to enter into BIOS setup page when system powers up.

Note: For some Lenovo laptop (Idea), there is a NOVO button to enter into system configuration. More details: Introduction to NOVO button

Note: For Windows 8.1 or 10, you can also manage to enter into BIOS in another way. More details: How to enter into BIOS in Windows 10

Step 2. Look for virtualization technology (aka Intel VT or AMD-V) and enable it. At the end, save and restart the computer to apply the change.

Note: The BIOS settings for Intel VT or AMD-V are usually in the Chipset or Processor menus. The menu names may vary from this guide, the virtualization settings may be found in Security Settings or other non standard menu names.

AMD processor:

Intel processor:

4. If get the result as below, you are probably ready to go with hardware virtualization now.

If you still get feature off warning, it’s probably conflicted with 3rd party software, check this post.

>> Back to MEmu 101, everything you need to know about MEmu <<

Source : http://www.memuplay.com/blog/index.php/2016/01/27/enable-hardware-virtualization/

Tags : MEmu, amd v, android emulator, hardware virtualization, intel vt, vt

Wednesday, July 26, 2017

Windows 7 Slow Access to Network Shares

One of my clients recently deployed Windows 7 across their network and are experiancing performance issues when accessing network resources involving MS-RPC calls such as network shares through the SMB protocol.  Windows Vista/2008/7 has a new TCP network stack to Windows XP/2003 and has a number of new technologies designed to increase network performance.

Windows XP/2003 clients are not receiving performance problems.

Issue

When a Windows 7 PC attempts to accesss file shares on any Windows XP/2003 servers, browsing performance of mapped network shares is aporling.  It feels simlar to accessing the file server over a VPN connection with poor bandwidth and high latency, however in this scenario we are accessing the file server over LAN.  We tested a Windows 7 client on the same 24bit subnet as a number of Windows 2003 file servers on a 1gbps network.  Slow access to network shares also occured over the same subnet.

What I did notice however was slow performance did not occur when a Windows Vista/2008/7 computer accesses file shares on another Windows Vista/2008/7.  The issue only occured when Windows Vista/2008/7 accessed Windows XP/2003.

This issue is not driver related, I ensured to test workstations of different driver architecture including Intel and Broadcom network drivers.

Workaround

After researching into this issue we came identified two Windows components contributing to the performance issues.

  • TCP Auto-Tuning
  • Remote Differential Compression

Do not disable these components unless you understand what they are and their purpose.

TCP Auto-Tuning

As mentioned above, a new TCP stack was implemented as of Windows Vista that aims to take full advantage of hardware advances such as gigabit networking. Among the new feature in the new TCP stack is Receive Window Auto-Tuning Level for TCP connections. TCP AutoTuning enables TCP window scaling by default and automatically tunes the TCP receive window size for each individual connection based on the bandwidth delay product (BDP) and the rate at which the application reads data from the connection, and no longer need to manually change TcpWindowSize registry key value which applies to all connection. Theoretically, with TCP auto-tuning, network connection throughput in Windows Vista should be improved for best performance and efficiency, without registry tweak or hack. However, this is not always the case, and may cause some performance related issues such as in our case.

The default auto-tuning level is "normal", and the possible settings for the above command are:

  • disabled: uses a fixed value for the tcp receive window. Limits it to 64KB (limited at 65535).
  • highlyrestricted: allows the receive window to grow beyond its default value, very conservatively
  • restricted: somewhat restricted growth of the tcp receive window beyond its default value
  • normal: default value, allows the receive window to grow to accommodate most conditions
  • experimental: allows the receive window to grow to accommodate extreme scenarios (not recommended, it can degrade performance in common scenarios, only intended for research purposes. It enables RWIN values of over 16 MB)

In my environment changing this from the default value of normal to restricted resolved my performance issues.

netsh int tcp set global autotuninglevel=restricted

Remote Differential Compression

Remote Differential Compression (RDC) is a client–server synchronization algorithm that allows the contents of two files to be synchronized by communicating only the differences between them. It was introduced with Windows Server 2003 R2 and is included with later Windows client and server operating systems.  As of Vista onwards Remote Differential Compression is enabled by default.

Microsoft does not recommend ever disabling Remote Differential Compression (RDC) unless there is an absolute need to.  Diane from Microsoft wrote a blog post entitled "Debunking Myths about Remote Differential Compression and System Performance" where she states:

A number of third-party blogs are telling people they can speed up Windows Update downloads, and file copy operations, by turning off the Remote Differential Compression (RDC) feature on Windows Vista. This is 100% false. Neither Windows Update or file copy operations use RDC at all.

The RDC feature is simply a DLL that does not consume any system resources, except when you run an application that uses RDC specifically. If you disable RDC, any application that uses it will either not be able to take advantage of RDC or will simply fail. For more information on RDC see this link http://msdn.microsoft.com/en-us/library/aa373254(VS.85).aspx.

As a result I do not recommend disabling RDC unless you have an absolute need to.  In my environemnt I tested my Windows 7 PC's with RDC turned on and RDC turned off.  When turned on I noticed my performance to Windows 2003/XP file shares diminished.  Please disable with care.

You can disable RDC through Windows Features in control panel:


You can also disable RDC through command line using the following command:


ocsetup MSRDC-Infrastructure /uninstall


Deploying the Workaround

I wrote a batch script to deploy this workaround to all Windows 7 computers on my network.  The batch script first identifies IS the computer running Windows 7, if so THEN set TCP Autotuning to Restricted and disable Remote Differential Compression.

Here is a copy of my script:
@echo off
systeminfo | find "OS Name" > %TEMP%\osname.txt
set /p vers=<%TEMP%\osname.txt
echo %vers% | find "Windows 7" > nul
if %ERRORLEVEL% == 0 goto ver_7
goto warnthenexit
:ver_7
ocsetup MSRDC-Infrastructure /uninstall
netsh interface tcp set global autotuning=restricted
goto exit
:warnthenexit
echo Machine undetermined.
:exit
Deploy this script to your workstations through a Group Policy Startup Script.

Note: Due to the Windows 7 performance issues I also needed to configure "Always wait for the network at computer startup and logon" under "Computer -- Administrative Templates -- System -- Logon"

Tags : WINDOWS CLIENT GENERAL, WINDOWS SERVER GENERAL

How to Earn Money From Your Xtgem Wapsite

How to Earn Money From Your Xtgem Wapsite

Introduction :

The primary aim of wapsite creation was to earn an enormous amount of money from it, But it is not an easy job. It consists a huge quantity of traffic and genuine clicks on the ads. Most of the wapmasters were trying to get click on their ads by placing their ads near at the downloading links etc. It will make the wapmasters ads disabled forever by the Advertising Network. Through this article, you are going to learn 'How to make money from your Xtgem wapsite'.

How to Setup Ads on My Xtgem Wapsite:

You can easily set up ads on your Xtgem wapsite. You can add some of the major Advertising company's ads directly through the development option of Xtgem.
Google

  • Adsense -BuzzCity - InMobi -Adiquity - This is the Major Ad network's Using 10000  Of Wapmasters. 

The above are the major advertising company's where most the wap master's where choosing to earn money from their wapsite. So I recommend you to select the following Advertising Network for making money from your wapsite.

Google Adsense:

In the case of Google Adsense, it is very hard to get approved. Google Adsense have some strict policies and regulations so they will not accept any site that is against their policies. If you created a blog on Xtgem that contain good and quality, contents that are not against the-the TOS of Adsense. Then your Xtgem blog surely gets Adsense approved.

BuzzCity-InMobi-Adiquity : 

BuzzCity - InMobi - Adiquity are so different from the Adsense ads, Their CPC is much lower than the Google Adsense. They will not pay high ECPM Rate. But most of the wapmasters where choosing the BuzzCity - InMobi - Adiquity for earning money, Because none of them have strict policies they just need the high amount of traffic.

Steps to Add Advertising Network Ads on Your Xtgem Wapsite:

It is very easy to add Advertising Network Ads on your Xtgem wapsite by following the steps, Only if you know the basic steps of creating wapsite on Xtgem wapsite builder.

First of all, you need to Sign-Up with any of the Ad-Network given above at the header of this topic, On this tutorial am taking Adiquity. If you don't have an A/c with Adiquity, then create one by click here.

  1. Log in to your Xtgem A/c.
  2. Enter to the site that you want to add the Ads.
  3. Click on the page you wish to add Ads from the File-Manager.
  4. Click on the "+" Button for adding new elements.
  5. On the "Advanced" Section click on the "Ads" Tab.
  6. On the new Tab, you can see the Major Ad-Network.
  7. Click on the "Adiquity" or any other you like.
  8. Enter your Adiquity A/c name on the "Text-area" and click on the "Add" Button.

I hope you well enjoyed this article. If you have any doubts or suggestions about this article, please let us know by using them comment box given below. Thanks.

Tags : Money, Wapmaster Tools, Xtgem

Friday, July 21, 2017

The RAID was lost, what should I do?

The RAID was lost, what should I do?

[About RAID Lost]

When a RAID-1 / RAID-5 / RAID-6 / RAID-10 lost a disk, the RAID status will change from healthy to degraded.

In general to say, RAID-1 array has mirror in every disk, you may read out the data from every disk if the file system is clean. A RAID-5 only allow one disk left, once two disks left the RAID-5, the RAID was broken. RAID-6 allow two disks left, once three disks left the RAID, the RAID was broken. After the RAID was broken / damaged, for the models that come with LCD may show "RAID: N/A" on the LCD.

Since JBOD and RAID-0 give you no redundancy, even only one disk left the RAID will lead the RAID to damaged and can not be rescued.

For RIAD-10, it was built as disk#1 and disk#2 for RAID-1 mirror pair, disk#3 and disk#4 for RAID-1 mirror pair, and then assemble two mirror pairs as RAID-0. Therefore if both disk#1 and disk#2 left the RAID, or both disk#3 and disk#4 left the RAID, it will damage the RAID and can't be rescued. If only one disk left every mirror pairs, for example, disk#1 and disk#3 left the RAID, the RAID status was changed to degraded. Compare RAID-10 with RAID-6, the latter can tolerate any two disks dropped out of the RAID. So RAID-6 is better than RAID-10 from the point of data safety.

Besides RAID was damaged, there is another reason that shows "RAID: N/A" due to the file system error. If the file system is not clean, Thecus NAS will not mount the file system and will disassemble the RAID, that is another reason that you may see the "RAID: N/A" message.

Here are some articles for your reference before we could go through,

What is S.M.A.R.T.
http://esupport.thecus.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=50

Why my disk shows warning even after bad block scan?
http://esupport.thecus.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=147

How to rebuild a degraded RAID?
http://esupport.thecus.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=28


[Important Information]

Before contacting Thecus staff,


1. Do NOT create a new RAID. According to the feedback from our customers, some user might re-create a new RAID because they assume the RAID will back after they "create" one. Once you create a new RAID, the original raw data will lost forever and can not be rescued.

2. Do NOT run file system check only if you know what you are doing. We recommend user doing this after cloned all disks, running it at cloned disk and keep the original disks on hand. Since file system checking will write to disks physically, once it failed, you still keep your original disks.

3. Do NOT try to reboot and reboot. If RAID was damaged, reboot won't help. Sometimes it might make it worse.

4. Do NOT try to plug in / out the disk, or change the tray. Keep the environment is the best way.

[Download NAS Configuration file]

Before contacting Thecus staff, please download NAS configuration file (conf.bin),

* x86 Firmware v2.xx.xx

It can be downloaded from [System / Config Mgmt] and then press [Download] button.

* x86 Firmware v3.xx.xx & x64 Firmware v1.xx.xx

It can be downloaded from [System Management/ Utility/ Config Mgmt] and then press [Download] button.

* x86 Firmware v5.xx.xx & x64 Firmware v2.xx.xx

It can be downloaded from [System Management/ Config Mgmt] and then press [Download] button.

After download the conf.bin, please submit a ticket on our support system and attach the conf.bin file. We might know more detail information, if possible please also provide the RAID level, file system and so on.

[Clone the disks]

In most cases, we recommend user to clone all disks, please refer to http://en.wikipedia.org/wiki/Disk_cloning.

[Publish your NAS on internet]

Thecus staff may also need to check the NAS remotely, please select one of the following methods to publish your NAS on the internet.

A. Public Fixed IP (most easy)

Just assign a public fixed IP on the NAS WAN port

B. DMZ (easy)

Enable Router DMZ function and fill in NAS WAN private IP in the Router DMZ column, and then tell me the router WAN IP.

For Example:
Router WAN IP is 139.175.55.244
NAS WAN IP is 192.168.1.100
Enable Router DMZ function and fill in 192.168.1.100 for DMZ, thus the Router will forward all connection of 139.175.55.244 from internet to NAS WAN IP 192.168.1.100, than I could access to the NAS.

C. Virtual Server (port forward) (a little difficult)

Assign port 22 and 80 (or 443) forward to NAS private IP, we also need the admin password to login, please change a new admin password and let me know what it is.

For method B and C, we also have a quick guide for reference, http://esupport.thecus.com/files/Thecus_Internet_Quick_Guide_20100701_v1.0.pdf


*** Backup is always the best way for data safety ***

Source : http://thecus.kayako.com/Knowledgebase/Article/View/177/2/the-raid-was-lost-what-should-i-do

Tags : Raid Lost, thecus, n16000, Problem Thecus

Wednesday, July 19, 2017

Enable SSH root login on Ubuntu 16.04 Xenial Xerus Linux Server/Desktop

Enable SSH root login on Ubuntu 16.04 Xenial Xerus Linux Server/Desktop

The following config will guide you through the process of enabling SSH root login on Ubuntu 16.04 Xenial Xerus Linux Server or Desktop. This guide assumes that you are in possession of root password and are able to login directly on your system as root user. Use the following guide, if you do not have a root's user password.

By default the root's ssh remote shell access is denied by default. Any attempt to remote login as root will result in Permission denied message:
$ ssh root@10.1.10.1
root@
10.1.10.1's password:
Permission denied, please try again.
root@
10.1.10.1's password:

In order to enable root ssh login on Ubuntu 16.04 Xenial Xerus Linux run the following command:
$ sudo sed -i 's/prohibit-password/yes/' /etc/ssh/sshd_config
or manually open sshd configuration file /etc/ssh/sshd_config and change line:
FROM:
PermitRootLogin prohibit-password
TO:
PermitRootLogin yes
Once you have made the above configuration change restart ssh daemon:
$ sudo systemctl restart sshd
After you restart sshd daemon you will be able to remotely login as a root user:

$ ssh root@10.1.10.1
root@
10.1.10.1's password:
Welcome to Ubuntu 16.04 LTS (GNU/Linux 4.4.0-22-generic x86_64)
 * Documentation:  https://help.ubuntu.com/
22 packages can be updated.
20 updates are security updates.

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.
Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.
 
Tags :  Ubuntu 16.04 Xenial Xerus, Linux, ServerSSHD, SSH_CONFIG, PERMITROOTLOGIN

Thecus NAS Data Recovery

Thecus NAS Data Recovery

Recovering data from Thecus NAS and Windows Storage systems involves the removal of the drives, making identical copies or clones of the drives and mounting on one of our virtual NAS/RAID systems where we rebuild a virtual copy of the data partition of the system then extract the data directly.

We are able to recover data from all Thecus NAS units including those in the list below. If your model is not shown, then it does not mean we are unable to recover. We have the technology and software to recover data from any NAS storage equipment and have developed in house many of the software tools we use.

In most cases we will not need the NAS unit in order to recover the data so that where possible, it leaves you to able set up a new system ready to receive your recovered data from the old drives.

Please contact us on 0800 072 3282 to talk about your Thecus data recovery.

1U4200XXX, 1U4600, C10GTR, D16000, N0204, N0503, N10850, N12000, N12000PRO, N12000V, N16000, N16000PRO, N16000V, N2200, N2200EVO, N2200PLUS, N2200XXX, N2310, N2520, N2560, N2800, N3200XXX, N4100EVO, N4100PRO, N4200, N4200Eco, N4200PRO, N4310, N4510U, N4510UPRO, N4520, N4560, N4800, N4800Eco, N5200XXX, N5500, N5550, N6850, N7510, N7700+, N7700PRO, N7700PROv2, N7700SAS, N7710, N7710-G, N8200XXX, N8800+, N8800PRO, N8800PROv2, N8800SAS, N8810U, N8810U-G, N8850, N8900, N8900V, V16810U, V2510, V4510, V4510U, V5510, V6810, V8810U, W12000, W16000, W2000, W4000, W5000, W8900.

Tags : Thecus NAS Data Recovery, Thecus NAS, Data Recovery

Sunday, July 16, 2017

WhatsApp DOWN - Messaging service still NOT WORKING for millions of users

WHATSAPP is still down across the UK and other parts of the world including Europe and Brazil with millions left unable to access popular messaging service. WhatsApp has confirmed the issues but there's currently no word on when things will get back to normal


9:30am UPDATE: WhatsApp has rushed-out a new update to its iPhone app.

The new software update lists a number of new features, most of which were included in an update released earlier this month.

Twitter users have speculated that the chat app update could be linked to the recent worldwide outage.

This has not been confirmed by WhatsApp.

6.45am UPDATE: Although many users appear to be back to normal there's still hundreds of WhatsApp fans who still can't access the app.

Down Detector is showing hundreds of outages this morning with problems continuing across the UK.

11.30 UPDATE: WhatsApp users are continuing to face connection issues tonight, with the popular app still not working for many people.

There is currently no ETA on when WhatsApp will be back online in the UK, however, the support team have provided a short update on the situation.

"WhatsApp is aware of the issue and working to fix it as soon as possible," a spokesperson told Engadget.

While information is still scarce, WhatsApp users around the globe are reporting that the popular messaging app does appear to be coming back online, although it's unclear just how long it will take for all servers to do the same.


Source : http://www.express.co.uk/life-style/science-technology/799948/WhatsApp-down-not-working-UK-outage-iPhone-Android

Tags : whatsapp update 2017, whatsapp update 2017 download, whatsapp update 2017 not working, whatsapp update 2017 problems, whatsapp update 2017 reviews

How to Install .NET Framework 3.5 on Windows Server 2012 R2

Most modern Windows applications require .NET Framework to work properly. The roles and features setup wizard Server Manager in Windows Server 2012 R2 allows to install two different versions of .NET Framework at a time – 3.5 and 4.5. The installation of .NET Framework 4.5 doesn’t usually cause any problems – it’s all very simple, however, it cannot be said about the installation of .NET 3.5.

install .NET Framework 3.5 windows 2012 r2

Actually, when trying to install .NET Framework 3.5 in Windows Server 2012 R2 with the standard settings, the following error message appears: «Installation of one of more roles, role services or features failed. The source files could not be found…».

.net framework 3.5 installation failed


The reason of this behavior is that .NET Framework 3.5 binary files are not a part of the local cache of the binary files that are saved to the server when the operating system is being installed. This is done under the concept of Features on Demand in Windows Server 2012 to reduce the amount of disk space occupied by the OS for its own needs.

Check if .NET Framework 3.5 is in the local depository using the Powershell command:

Get-WindowsFeature *Framework*

powershell get framework status

As you can see, the required component is deleted (Install State: Removed)

By default, the system tries to download the necessary files from Windows Update (local WSUS server is not suitable for this purpose), and if this is not possible, the user is prompted to specify the path to the OS distribution, from which the missing component could be installed.

To install .NET Framework 3.5 manually, click Specify an alternative source path to enter an alternative path to a folder containing the installation disk of Windows Server 2012 R2.

specify alternative path .net installation

As the path, you can specify either a local folder (in our example it is D:\source\sxs, where D:\ is a letter of the local DVD drive with a Windows Server distribution), or a network folder.

windows server 2012r2 sxs sources

By clicking OK, the system will find .NET Framework 3.5 binaries and install the component.

installation of dot net framework 35 failed

The same operation can be performed from the command line by running the following command as an administrator:

dism /online /enable-feature /featurename:NetFX3 /all /Source:d:\sources\sxs /LimitAccess

/Online means that you need to upgrade your current OS, and not the image

/enable-feature/featurename: NetFX3/all means that it is necessary to install .NET Framework 3.5 with all its features

/Source is the path to the directory with Windows distribution, which contains the necessary components

/LimitAccess prevents accessing Windows Update

dism install framework35

The same operation in Powershell looks like this:

Add-WindowsFeature NET-Framework-Core -Source d:\sources\sxs
Path to the «original» Windows distribution can be fixed in the system on an ongoing basis using:

  • A registry setting RepairContentServerSource that is located in the HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Servicing branch
  • Or a group policy Specify settings for optional component installation and component repair (the policy changes this setting in the registry)

gpo specify component source path

Note. The group policy Specify settings for optional component installation and component repair is in the following section GPO: Computer Configuration -> Administrative Templates -> System. The policy should be enabled  and the path to the directory with the OS distribution should be specified (Alternative source file path). To prevent the server from trying to update online, check the box Never attempt to download payload from Windows Update.

Source : http://woshub.com/how-to-install-net-framework-3-5-in-windows-server-2012-r2/